Reconfiguration of Server lead to Optimize fail

Hi I have followed all the steps of setting up the Stape server and since we are running both GA and GA4 added two tags to server side, both working just fine. The problem I have is that we also use Google Optimize setup via WEB GTM that seems to show an error now:
Request URL: https://otokdzgi.eu.stape.io/gtm/optimize.js?id=OPT-WPHXXXX
Status Code: 404

I’ve check in the SERVER tag but there is no Google Optimize tag to setup, how can I make it work?

There is no support for Google Optimize on the server GTM.

Also, I am not sure how you get this URL " https://otokdzgi.eu.stape.io/gtm/optimize.js?id=OPT-WPHXXXX "
It is not valid. Basically, if you use the Optimize tag on GTM web container URL for the script would look like this: https://www.googleoptimize.com/optimize.js?id=OPT-WPHXXXX

Thanks @Denis , I’ve configured the GTM server using Stape server provided and not sub-domain. After configuration the https://otokdzgi.eu.stape.io/gtm/optimize.js?id=OPT-WPHXXXX shows in the Inspector / Network when I search for Stape server string: otokdzgi…

I’m guessing that since server transfer was changed in the gtm to poin to otokdzgi.eu.stape.io that’s what Optimize tag took. Does this makes more sense?

Yes, you have an interesting case.

Basically, I investigated your issue more deeply and found that this happens if you use a legacy domain inside your optimize tag on WEB GTM.
If you switch to a new domain inside the tag all will be fine.

Thanks for this community post and the question we will investigate more why this happens and provide a fix for legacy domain setting automatically to our customers. We plan to do this in the next two weeks.