Matomo Advanced Tag not registering any page views

We’ve recently begun using the Matomo Advanced tag for server-side tracking with Matomo. Everything appears to be tracked correctly, except Matomo is not registering any page views.

Here is an excerpt from the HTTP POST: idsite=2&rec=1&action_name=page_view&url=. Shouldn’t the action_name parameter contain the title of the page being tracked, rather than the type of action? Currently, it’s set to “page_view”.

screenshot Matomo

Hi Tore, yes correct. Try to set action_name to page title. This is what Matomo documentation says:

  • action_name (recommended) — The title of the action being tracked. For page tracks this is used as page title. If enabled in your installation you may use the category tree structure in this field. For example, “game / register new user” would then create a group “game” and add the item “register new user” in it.

Hi Ira,

Thank you for your response.

I’m currently utilizing the Matomo Advanced tag template provided by Stape (with GA4 schema). Shouldn’t this issue be resolved within the template itself? Additionally, I’m unsure if addressing this would rectify the problem of not registering any page_views.

Given that the action_name parameter is set as “page_view”, Matomo should still have registered the page views. However, it would erroneously label all page views with the title “page_view”, thereby making it difficult to distinguish between different pages in our analytics data.

Thus, even though having “page_view” as the action_name was likely a misconfiguration, it shouldn’t have hindered Matomo from registering page views completely. This suggests there might be other issues at play, particularly because no page views are being registered at all.

Hi Tore, we are working on Matomo tag improvements and will include action_name parameter fix.

I would suggest testing your setup with action_name set to page title.

Bellow, I also included an example of the request that records pageviews correctly so you can compare it with the request you have, maybe some parameters are missing.


I adjusted the action_name parameter in the template code to eventData.page_title. Although this didn’t have any effect on registering pageviews, it did correct the information.

Upon examining the HTTP post you shared, I noticed you submitted significantly fewer parameters than what’s default in the template. Consequently, I removed the following parameters: rand, cid, pv_id, and link. After making this change, I began seeing pageviews in Matomo. I haven’t yet had time to identify which of these parameters enabled it to work.

1 Like

I’m having the same issue. Weirdly for me the “action_name” Parameter doesn’t show up at all in the Request (Using the current version from github, with the Custom Page_View Event).

If I try to add the action_name as an additional Event Parameter is still doesn’t show up in the request.
Do I need to add it somewhere else?