404 page shopify

Good morning guys, i tried to configure stape on shopify;
when I test from the GTM server side container, unfortunately I always get a 404 page.

What should I change?

I am not using the stape app but we have GTM (web container) installed correctly;

Here is the configuration:

Many thanks!

Hi Giovanni,
The URL for the server container debug should contain your subdomain: https://sgtm.pumpmybooty.com… and now looks like you are missing it

Hi Vlad,

thanks for the answer.
I set up yesterday gtm server container with the following setting

I thought it was a matter of time, but nothing changed from yesterday.
Do you have any “check” to suggest?

Many thanks

Server container settings look correct. So when you click preview on the server container you get 404? As on your first screenshot you are missing subdomain and that seems to be the issue

Yep, I totally agree with you;

I really do not understand why shopify seems to not apply the changes with the setting of record A (sgtm);

However, I couldn’t create a subdomain in shopify because of the shopify domain’s rule: shopify doesn’t accept IP address different from shopify IP address;
our domain it’s hosted on shopify;

So I only set up A record;

Do you think that’s the reason why we’re facing this problem?
Do you have any other tips to suggest?

Many thanks

It’s all ok that you created just an A record on Shopify admin - no need to do anything else. Your server container is up and running and there are no problems with it.
Can you send a screenshot of what happens when you go to your server GTM container and click Preview? Is it where you get 404?

This is what’s happening

Hi Giovanni,
That is indeed strange behavior, but on your screen record I can see that when you click Preview on the server container, the URL your browser is trying to open is https://sgtm.pumpmybooty.com…, but is instantly redirected to a link without the subdomain. There is no problem for me to open that URL, please see the screenshot. So maybe you have some problem locally, try using Incognito window, another device, clear cache, things like that

1 Like